- NetBSD Manual Pages
DL(4) NetBSD/vax Kernel Interfaces Manual DL(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dl -- DL-11/DLV-11 serial device driver
dl0 at uba? csr 0176500
dl1 at uba? csr 0176510
dl2 at uba? csr 0176520
dl3 at uba? csr 0176530
The dl driver controls a DL-11-compatible asynchronous serial card, and
probably things compatible with it. A four-port DLV-11J will appear four
times in the device list, as the ports look like separate cards to the
The dl driver provides the normal interface described in tty(4), but many
of the configuration calls are unsupported, since their functions are
handled by jumpers or switches on the serial card itself. Calls related
to modem-control lines are also ignored, since these cards lack them.
There's a chance this driver might also work with an LP11, an LPV11 or
even a PC11, but it hasn't been tested.
/dev/ttyJ? Special files for communicating with dl devices.
dl%d: rx overrun. The character in the receive buffer wasn't read before
the next character arrived, and has been lost.
dl%d: stray rx interrupt. The driver was called to service a receive
interrupt, but there was nothing for it to read.
The dl driver was written for NetBSD 1.3.
Ben Harris <bjh21@NetBSD.org>
The DL-11 and friends only have single-character receive and transmit
buffers, so an interrupt is generated for every character received or
transmitted. Attempting to receive data at even moderately high rates
will cause rx overruns. Fast transmission seems to be fine though.
There is no support in the driver for the paper-tape reader on an LT33
attached via a DLV-11KA or similar.
The overrun message is logged in the interrupt routine itself, which will
probably just make the problem worse.
The CSR printed on startup is that of the receiver, while the interrupt
vector is that of the transmitter.
In order to determine the card's interrupt vector, the driver sends a NUL
to each port. This may confuse things attached to them.
The driver has so far only been tested on a DLV-11J. It may or may not
work on the other cards it claims to support.
NetBSD 9.1 January 28, 1997 NetBSD 9.1