- NetBSD Manual Pages
DHU(4) NetBSD/vax Kernel Interfaces Manual DHU(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dhu -- DHU-11/DHV-11 serial communications multiplexer
dhu0 at uba0 csr 0160440
A DHU-11 provides 16 communication lines.
Normal I/O control parameters for individual lines are managed by
ioctl(2) calls. Individual DHU-11 lines may be configured to run at any
of 13 speeds (50, 200 and 38400 baud are not available); the speed may be
set via getty(8) or stty(1) or may be communicated by other programs
which use ioctl(2) such as ifconfig(8), see tty(4).
The DHU-11 driver normally uses input silos and delays receiver inter-
rupts by 20 milliseconds rather than taking an interrupt on each input
The driver currently does not make full use of the hardware capabilities
of the DHU-11, for dealing with XON/XOFF flow-control or hard-wired lines
Although the devices are not the same, a DHU-11 can convince the DH-11
autoconfiguration code that it is a DH-11.
The 4 40-way cables are a pain.
The dhu driver appeared in 4.3BSD.
A new dhu driver showed up in NetBSD 1.2.
Even if the dhu hardware supports DMA, the driver cannot make use of this
NetBSD 9.1 June 5, 1993 NetBSD 9.1