- NetBSD Manual Pages
DH(4) NetBSD/vax Kernel Interfaces Manual DH(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dh -- DH-11/DM-11 serial multiplexer device interface
dh0 at uba0 csr 0160020 vector dhrint dhxint [flags]
dm0 at uba0 csr 0170500 vector dmintr [flags]
NOTE: This driver has not been ported from 4.4BSD yet.
A DH-11 provides 16 serial communication lines; DM-11s may optionally be
paired with DH-11s to provide modem control for the lines.
An optional argument flags may be supplied with the device specification
in the config(1) file indicating that the line corresponding to bit num-
ber i is not properly connected, and should be treated as hard-wired with
carrier always present. Thus specifying `flags 0x0004' for dh0 would
cause line ttyh2 to be treated in this way.
Normal I/O control parameters for individual lines are managed by
ioctl(2) calls. Line speeds may be initiated via getty(8) and stty(1) or
may be communicated by other programs which use ioctl(2) such as
ifconfig(8), see tty(4).
The dh driver monitors the rate of input on each board, and switches
between the use of character-at-a-time interrupts and input silos. While
the silo is enabled during periods of high-speed input, the driver polls
for input 30 times per second.
dh%d: NXM. No response from UNIBUS on a DMA transfer within a timeout
period. This is often followed by a UNIBUS adapter error. This occurs
most frequently when the UNIBUS is heavily loaded and when devices which
hog the bus (such as RK07s) are present. It is not serious.
dh%d: silo overflow. The character input silo overflowed before it could
be serviced. This can happen if a hard error occurs when the CPU is run-
ning with elevated priority, as the system will then print a message on
the console with interrupts disabled. It is not serious.
A dh driver appeared in Version 6 AT&T UNIX.
NetBSD 9.1 June 5, 1993 NetBSD 9.1