- NetBSD Manual Pages
INTRO(4) NetBSD/sparc64 Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to sparc64 special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
This section describes the hardware supported on the SPARC64 platform.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system must be rebooted.
The autoconfiguration system is described in autoconf(4). A list of the
supported devices is given below.
config(1), autoconf(4), cd(4), cgsix(4), ch(4), kbd(4), le(4), magma(4),
mem(4), ms(4), openprom(4), scsi(4), sd(4), ss(4), st(4), tcx(4), uk(4)
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
auxio Auxiliary I/O & LED
bpp Bi-directional Parallel port
cgsix 8 bit obio (sun4c & sun4m), Sbus color graphics frame
com PC-style serial port
eeprom Sun non-volatile configuration RAM driver
esp ESP200 SCSI controller
FSBE/S (X1053A, part # 501-2015) Fast SCSI-2/Buffered Eth-
ernet Sbus controller
fdc Floppy Disk Controller
ffb Creator & Creaor3D graphics frame buffer
isp Qlogic ISP Sbus and PCI SCSI controller
kbd Sun type 2, type 3, type 4, and type 5 keyboards (on zs or
le/lebuffer AMD 7990 LANCE Ethernet controller
lpt PC-style parallel port
magma Magma Sp Serial/Parallel board device driver
ms Sun mouse (on zs or com)
openprom Sun Open boot PROM (what became IEEE 1275) configuration
power power management halt(8) and shutdown(8) commands can use
it to power down the system.
sab Siemens 82532 & 83538 serial controller
zs Zilog 8530 serial controller
PCI devices are supported through the pci(4) bus and associated devices.
PCMCIA devices are supported through the pcmcia(4) bus and associated
Cardbus devices are supported through the cardbus(4) bus and associated
USB devices are supported through the usb(4) bus and associated devices.
The following devices are not supported, due to unavailability of either
documentation, sample hardware, or willing volunteer:
atifb ATI 3D Rage Pro VGA graphics adapter (Ultra5, Ultra10)
fdc sun4u floppy drive controllers (EBus based machines only)
cgfourteen 24 bit Sbus color frame buffer
cgthree 8 bit Sbus color frame buffer
This sparc64 intro appeared in NetBSD 1.6. Large chunks of text care-
fully recycled (shamelessly appropriated) from NetBSD/sparc intro.
NetBSD 9.1 May 10, 2007 NetBSD 9.1