- NetBSD Manual Pages
INTRO(4) NetBSD/sparc Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to sparc special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
This section describes the hardware supported on the SPARC platform.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system must be rebooted.
The autoconfiguration system is described in sparc/autoconf(4). A list
of the supported devices is given below.
config(1), cd(4), ch(4), le(4), scsi(4), sd(4), sparc/autoconf(4),
sparc/bwtwo(4), sparc/cgeight(4), sparc/cgfour(4), sparc/cgfourteen(4),
sparc/cgsix(4), sparc/cgthree(4), sparc/cgtwo(4), sparc/fd(4),
sparc/kbd(4), sparc/magma(4), sparc/mem(4), sparc/ms(4),
sparc/openprom(4), sparc/tcx(4), ss(4), st(4), uk(4)
The following Sun SPARC system architectures and models are supported:
sun4 first generation SPARC systems on VMEbus:
Sun 4/100 series (14.28 MHz)
Sun 4/200 series (16.67 MHz)
Sun 4/300 series (25 MHz)
sun4c desktop SPARC systems with Sbus:
SPARCstation 1 (20 MHz)
SPARCstation 1+ (25 MHz)
SPARCstation 2 (40 MHz)
SPARCstation SLC (20 MHz)
SPARCstation ELC (33 MHz)
SPARCstation IPC (25 MHz)
SPARCstation IPX (40 MHz).
sun4m desktop SPARC systems with Mbus for CPUs, and Sbus:
SPARCclassic (50 MHz microSPARC I)
SPARCstation LX (50 MHz microSPARC I)
SPARCstation 4 (70 MHz microSPARC II)
SPARCstation 5 (70, 85, 110 MHz microSPARC II)
SPARCstation 5 (170 MHz TurboSPARC)
SPARCstation 10M (36 MHz SuperSPARC I)
SPARCstation 20M (50 MHz SuperSPARC I)
SPARCstation 10 (Mbus modules)
SPARCstation 20 (Mbus modules)
The SPARCstation 2 and IPX can be upgraded with a Weitek PowerUP CPU that
is clock-doubled (i.e. internally it runs at 80 MHz). NetBSD supports
Hardware level clones of these systems from other manufacturers will
likely work (e.g. Xerox, Tatung, Axil, Cycle); other systems which have a
SPARC CPU but do not use Sun's hardware architecture (e.g. Solbourne)
will likely not work.
The sun4m architecture with Mbus modules for the CPUs is supported with
the following modules with only one CPU:
SM41 40 MHz SuperSPARC I with 1MB SuperCACHE
SM51 50 MHz SuperSPARC I with 1MB SuperCACHE
SM61 60 MHz SuperSPARC I with 1MB SuperCACHE
SM71 75 MHz SuperSPARC II with 1MB SuperCACHE
SM81 85 MHz SuperSPARC II with 1MB SuperCACHE
HS11 100 MHz Ross Technology hyperSPARC
HS21 125 MHz Ross Technology hyperSPARC
M151 150 MHz Ross Technology hyperSPARC
This list is not exhaustive; NetBSD is continuously being improved, and
may well run on Mbus CPU modules not listed here.
There is also some support for Sun JavaStation computers based on the
NetBSD does not yet properly support multiprocessor systems, but will run
on one processor of a multiprocessor system.
The Sun 4/400 series, and sun4d (SPARCcenter 1000, 1000E, and 2000) are
The sun4u (UltraSPARC 64-bit) architectures are supported by
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
audio AMD 79C30 obio (sun4c) and dbri (sun4m) audio controller
bpp Bi-directional Parallel port
bwtwo black and white obio frame buffer
cgeight 24 bit VMEbus color frame buffer
cgfour 8 bit obio (sun4 P4 bus) color graphics frame buffer
cgfourteen 24 bit Sbus color frame buffer
cgsix 8 bit obio (sun4c & sun4m), Sbus color graphics frame
cgthree 8 bit VMEbus, Sbus, and obio (sun4m) color graphics frame
cgtwo 8 bit VMEbus color frame buffer
dbri Dual Basic Rate Interface (BRI) ISDN (SPARC LX & SPARCsta-
tion 10) (only the audio component is supported)
eeprom Sun non-volatile configuration RAM driver
esp NCR53C90 ESP100 (Sun 4/300), ESP100A (sun4c), ESP200
(sun4m) SCSI controller
FSBE/S (X1053A, part # 501-2015) Fast SCSI-2/Buffered Eth-
ernet Sbus controller
fd Intel 82072 obio (sun4c) or Intel 82077 obio (sun4m)
floppy disk drive controller
ie Intel 82586 Ethernet controller (Sun 4/100)
isp Qlogic ISP Sbus SCSI controller
kbd Sun type 2, type 3, type 4, and type 5 keyboards (on zs)
le/lebuffer AMD 7990 LANCE Ethernet controller (Sun 4/200, 4/300,
sun4c, sun4m, Sbus)
magma Magma Sp Serial/Parallel board device driver
ms Sun mouse (on zs)
openprom Sun Open boot PROM (what became IEEE 1275) configuration
power sun4m power management; the halt(8) and shutdown(8) com-
mands can use it to power down the system.
si NCR5380 "SCSI-2" VMEbus (Sun 4/200, Sun 4/400) SCSI con-
sw NCR5380 obio (Sun 4/100) "SCSI Wierd" SCSI controller
tcx 8 or 24 bit Sbus color graphics frame buffer
xd Xylogics 753/7053 VMEbus SMD disk controller
xy Xylogics 450/451 VMEbus SMD disk controller
zs Zilog 8530 serial controller
The following devices are not supported, due to unavailability of either
documentation or sample hardware:
dbri Dual Basic Rate Interface (BRI) ISDN (SPARC LX & SPARCstation
This sparc intro appeared in NetBSD 1.3. Large chunks of text carefully
recycled (shamelessly appropriated) from NetBSD/pmax intro.
NetBSD 9.1 February 17, 2017 NetBSD 9.1