- NetBSD Manual Pages
SPLRAISE(9) NetBSD Kernel Developer's Manual SPLRAISE(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
spllower, splraise -- modify system interrupt priority level
These functions raise and lower the interrupt priority level on i386.
They are used by machine-dependent kernel code to implement the machine-
independent spl(9) interface.
In a multi-CPU system, these functions change the interrupt priority
level on the local CPU only. In general, device drivers should not make
use of these functions.
The spllower() function sets the system priority level to the one encoded
in s, if s is lower than the current level. Otherwise, it does not
change the level. Use splx() instead of spllower(), except in extraordi-
The splraise() function sets the system priority level to the one encoded
in s, if s is greater than the current level, and returns the previous
level. Otherwise, it does not change the level, and it returns the cur-
rent level. Except in extraordinary circumstances, do not use
splraise(). Use one of the priority-raising functions defined in spl(9),
condvar(9), mutex(9), rwlock(9), spl(9)
NetBSD 9.1 February 5, 2010 NetBSD 9.1