- NetBSD Manual Pages
IO(4) NetBSD/i386 Kernel Interfaces Manual IO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
io -- I/O privilege file
This device is obsolete and is provided for compatibility purposes only;
use i386_iopl(2) instead.
After opening /dev/io for writing the process is granted full I/O privi-
leges; closing the returned file descriptor does not result in revocation
of these privileges. The new I/O privileges can be useful in order to
write userland programs that handle some hardware directly.
The entire access control is handled by the file access permissions of
/dev/io, so care should be taken in granting rights for this device.
I/O privilege on access to /dev/io is only granted if the kernel was
built with the COMPAT_10 option.
The io file appeared in NetBSD 1.0 after it was in the kernel for some
NetBSD 9.1 January 1, 1996 NetBSD 9.1