- NetBSD Manual Pages
I2CSCAN(8) NetBSD System Manager's Manual I2CSCAN(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
i2cscan -- scan an IIC bus for devices
i2cscan [-r] i2cdev
The i2cscan utility scans the Inter-Integrated Circuit bus (iic(4)) spec-
ified by i2cdev to determine which addresses respond.
i2cdev can be specified with or without the /dev prefix. For example,
/dev/iic0 or iic0.
-r scan using 1 byte reads instead of quick writes.
WARNING! Using this utility can access some devices in such a manner as
to leave them in an unstable or unusable state. It can also lock up the
entire iic(4) bus. Don't use this utility unless you know what you're
doing and can accept all sorts of unforeseen consequences.
The i2cscan utility exits 0 on success, and >0 if an error occurs.
Scan the first IIC bus found on the system for devices:
NetBSD 9.1 November 26, 2015 NetBSD 9.1