- NetBSD Manual Pages
GENFB(4) NetBSD Kernel Interfaces Manual GENFB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
genfb -- generic framebuffer console driver
genfb* at pci?
genfb* at sbus?
genfb* at intvid? (mac68k)
genfb* at macvid? (mac68k)
wsdisplay* at genfb?
The genfb driver provides support for generic framebuffers that have no
native driver. All it needs are some parameters to describe the frame-
buffer and an address.
When attaching to a pci(4) bus the driver is configured via device prop-
Width in pixels.
Height in pixels.
Line size in bytes.
Bits per pixel.
If true, genfb will try to become the system console.
Bus address of the framebuffer.
When attaching to sbus(4) all those parameters are retrieved from the
All those parameters are configured with Mac OS, and retrieved from the
mac68k/intro(4), pci(4), sbus(4), wscons(4), wsdisplay(4)
There is no way to change the color map even when the firmware supports
it. The pci(4) bus frontend has only been tested on macppc, i386, and
amd64 and requires machine dependent code to pass the properties men-
tioned above. So far only macppc, i386, and amd64 provides them.
NetBSD 9.1 July 26, 2019 NetBSD 9.1