- NetBSD Manual Pages
SPDMEM(4) NetBSD Kernel Interfaces Manual SPDMEM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
spdmem -- Generic Memory Module Serial Presence Detect
spdmem* at iic? addr 0x50
spdmem* at iic? addr 0x51
spdmem* at iic? addr 0x52
spdmem* at iic? addr 0x53
spdmem* at iic? addr 0x54
spdmem* at iic? addr 0x55
spdmem* at iic? addr 0x56
spdmem* at iic? addr 0x57
The spdmem driver provides support for generic memory module Serial Pres-
ence Detect. During kernel boot it displays module type, and where pos-
sible, the size and rated speed of the memory module. Additional infor-
mation such as bank configuration and width is printed if the kernel is
booted in verbose mode.
The Serial Presence Detect data for each memory module is also made
accessible to user mode via sysctl(8). An entry for each spdmem device
is created under the hw top-level MIB.
Some SPD ROMs also have a temperature sensor. It's supported by
iic(4), intro(4), sdtemp(4)
The spdmem driver first appeared in NetBSD 5.0.
The spdmem driver was written by Nicolas Joly <email@example.com> with
additional work by Paul Goyette <firstname.lastname@example.org>.
NetBSD 9.1 July 27, 2016 NetBSD 9.1