- NetBSD Manual Pages
SEEPROM(4) NetBSD Kernel Interfaces Manual SEEPROM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
seeprom -- 24-series I2C EEPROM driver
seeprom0 at iic0 addr 0x51: AT24Cxx or compatible EEPROM: size 256
seeprom16 at iic1 addr 0x57: power-supply: size 8192
The seeprom driver provides support for the ATMEL 24-series of I2C EEP-
ROMs, and compatibles, available from a variety of vendors. The Philips
PCF8582 is also supported, as compatible with the AT24C02.
Access to the contents of the memory is through a character device.
The size of the EEPROM is either read from the firmware, or can be set
using the flags keyword in the kernel configuration. The value of the
flag represents the EEPROM size in Kbit.
flags EEPROM size in bytes
seeprom* at iic? addr 0x51 flags 0x2
seeprom* at iic? addr?
The seeprom device appeared in NetBSD 2.0.
AT24C1024 EEPROM's are not supported.
Software write protection on the AT34Cxx EEPROMs is not supported.
The seeprom driver reads and writes one byte at a time to be compatible
with all controllers.
NetBSD 9.1 October 25, 2013 NetBSD 9.1