- NetBSD Manual Pages
MOUNT_OVERLAY(8) NetBSD System Manager's Manual MOUNT_OVERLAY(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mount_overlay -- mount an overlay filesystem; demonstrate the use of an
overlay file system layer
mount_overlay [-o options] /overlay mount-point
The mount_overlay command creates an overlay layer, interposing the over-
lay filesystem between the over-mounted file store and future pathname
A different device number for the virtual copy is returned by stat(2),
but in other respects it is indistinguishable from the original.
The mount_overlay filesystem differs from the null filesystem in that the
mount_overlay filesystem does not replicate the sub-tree, it places
itself between the sub-tree and all future access.
The overlay layer has two purposes. First, it serves as a demonstration
of layering by providing a layer which does nothing other than insert
itself over the over-mounted file system. Second, the overlay layer can
serve as a prototype layer. Since it provides all necessary layer frame-
work, new file system layers which need to block access to the overlayed
file system can be created very easily by starting with an overlay layer.
The internal operation of the overlay layer is identical to that of the
null layer. See its documentation for details.
UCLA Technical Report CSD-910056, Stackable Layers: an Architecture for
File System Development.
The mount_overlay utility first appeared in NetBSD 1.5.
NetBSD 9.1 January 18, 2000 NetBSD 9.1