- NetBSD Manual Pages
DUMPLFS(8) NetBSD System Manager's Manual DUMPLFS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dumplfs -- dump file system information
dumplfs [-adiS] [-b blkno] [-I blkno] [-s segno] filesys | device
dumplfs prints out the file system layout information for the LFS file
system or special device specified. The listing is very long and
detailed. This command is useful mostly for finding out certain file
system information such as the file system block size.
The following flags are interpreted by dumplfs.
-a Dump the contents of all superblocks, not just the first.
Superblocks appear in the dumplfs output with the segment con-
-b Use the block specified immediately after the flag as the super
block for the filesystem.
-d Check partial segment data checksums and report mismatches. This
makes dumplfs operate much more slowly.
-I Use the block specified immediately after the flag as the inode
block containing the index file inode.
-i Dump information about the inode free list.
-S Dump information about the segment table.
-s Add the segment number immediately following the flag to a list
of segments to dump. This flag may be specified more than once
to dump more than one segment. The default is to dump all seg-
disktab(5), fs(5), disklabel(8), newfs_lfs(8)
The dumplfs command appeared in 4.4BSD.
NetBSD 9.1 June 13, 2000 NetBSD 9.1