- NetBSD Manual Pages
DDC(4) NetBSD Kernel Interfaces Manual DDC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ddc -- VESA Display Data Channel V2 devices
ddc at iic? addr 0x50
The ddc driver provides support for accessing the VESA Display Data Chan-
nel Version 2 supported by many video displays.
iic(4), ddc(9), edid(9)
The ddc device appeared in NetBSD 4.0.
Garrett D'Amore <gdamore@NetBSD.org>
This driver does not provide any mechanism for access from user applica-
tions. Its only use at this point is to provide a means for framebuffer
device drivers to query monitor description data (EDID) using a special-
ized in-kernel API. No support for sending control commands to display
devices is provided.
NetBSD 9.1 May 11, 2006 NetBSD 9.1