- NetBSD Manual Pages
CTASSERT(9) NetBSD Kernel Developer's Manual CTASSERT(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
CTASSERT -- compile time assertion macro
The CTASSERT() macro evaluates expression at compile time and causes a
compiler error if it is false.
The CTASSERT() macro is useful for asserting the size or alignment of
important data structures and variables during compilation, which would
otherwise cause the code to fail at run time.
The CTASSERT() macro should not be used in a header file. It is imple-
mented using a dummy typedef, with a name (based on line number) that may
conflict with a CTASSERT() in a source file including that header.
Assert that the size of the uuid structure is 16 bytes.
CTASSERT(sizeof(struct uuid) == 16);
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
NetBSD 9.1 January 24, 2010 NetBSD 9.1