- NetBSD Manual Pages
NP(4) NetBSD/vax Kernel Interfaces Manual NP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
np -- Interlan Np100 10 Mb/s Ethernet interface
np0 at uba0 csr 166000 vector npintr
NOTE: This driver has not been ported from 4.4BSD yet.
The np device provides access to an Interlan Np100 Ethernet interface for
This interface is unusual in that it requires loading firmware into the
controller before it may be used as a network link-level interface. This
is accomplished by opening a character special device, and writing data
to it. It is also possible to do post-mortem debugging of firmware fail-
ures by reading the local memory of the device.
Multiple control processes are allowed by opening separate minor devices;
secondary interfaces are specified by shifting the interface number by 4
The device also responds to commands passed through the driver by the
NPRESET kills off all active network processes.
NPSTART begins execution of the board at the specified address (usu-
NPNETBOOT downloads the image from a server on the network. [Contact
MICOM-INTERLAN for details.]
np%d: Bad Maintenance command: %x! An invalid ioctl(2) was passed to the
np%d: Panic NP100 bad buffer chain. An error occurred in an read or
write operation causing it to run out of buffers before it finished the
operation. This indicates a kernel failure rather than a device failure.
NP100 unit %d not found! A failure occurred during initialization, such
that the UNIBUS address expected for the board was found to be bad.
Probably indicates hardware problems with the board, as do the following:
NP100 Unit %d timed out!
NP100 Unit %d Failed diagnostics!
Status from CSR0: %x.
Panic from NP100 unit %d!
Panic Message: %s. An occurrence on the board was deemed serious enough
to have the VAX print it out.
NP100 unit #%d available! The board was successfully loaded and started.
np%d: Bad Req: %x. The board made a maintenance request to the VAX that
it did not understand.
np%d: No more room on Command Queue! The np driver allowed an internal
resource to be exhausted. This should never happen.
There are 110 other diagnostic messages that can be enabled by setting
bits in a debugging mask. Consult the driver for details.
arp(4), inet(4), netintro(4), vax/ix(4)
The np driver appeared in 4.3BSD.
NetBSD 9.0 February 17, 2017 NetBSD 9.0