- NetBSD Manual Pages
EX(4) NetBSD/vax Kernel Interfaces Manual EX(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ex -- Excelan 10 Mb/s Ethernet interface
ex0 at uba0 csr 164000 vector excdint
NOTE: This driver has not been ported from 4.4BSD yet.
The ex interface provides access to a 10 Mb/s Ethernet network through an
Excelan controller used as a link-layer interface.
Each of the host's network addresses is specified at boot time with an
SIOCSIFADDR ioctl(2). The ex interface employs the address resolution
protocol described in arp(4) to dynamically map between Internet and Eth-
ernet addresses on the local network.
ex%d: HW %c.%c, NX %c.%c, hardware address %s. This provides firmware
revisions levels, and is expected during autoconfiguration.
ex%d: can't initialize. There was a failure in allocating UNIBUS
resources for the device.
ex%d: configuration failed; cc = %x. The hardware indicated an error
when trying to initialize itself. The error code returned is described
at length in the device Reference Manual.
ex%d: receive error %b. The hardware indicated an error in reading a
packet from the cable. Specific Error bits are provided
ex%d: transmit error %b. The hardware indicated an error in transmitting
a packet to the cable or an illegally sized packet. Specific Error bits
ex%d: can't handle af%d. The interface was handed a message with
addresses formatted in an unsuitable address family; the packet was
arp(4), inet(4), netintro(4)
The ex driver appeared in 4.3BSD.
NetBSD 9.0 February 5, 2019 NetBSD 9.0