- NetBSD Manual Pages
DN(4) NetBSD/vax Kernel Interfaces Manual DN(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dn -- DN-11 serial autocall unit interface
dn0 at uba? csr 0160020 vector dnintr
NOTE: This driver has not been ported from 4.4BSD yet.
The dn device provides an interface through a DEC DN-11 (or equivalent
such as the Able Quadracall) to an auto-call unit (ACU). To place an
outgoing call one forks a sub-process which opens the appropriate call
unit file, /dev/cua? and writes the phone number on it. The parent
process then opens the corresponding modem line /dev/cul?. When the con-
nection has been established, the open on the modem line /dev/cul? will
return and the process will be connected. A timer is normally used to
timeout the opening of the modem line.
The codes for the phone numbers are:
0-9 number to be dialed
* dial * (`:' is a synonym)
# dial # (`;' is a synonym)
- delay 20 milliseconds
< end of phone number (`e' is a synonym)
= delay for a second dial tone (`w' is a synonym)
f force a hangup of any existing connection
The phone number to be dialed must be presented as one contiguous string.
By convention, even numbered call units are for 300 baud modem lines,
while odd numbered units are for 1200 baud lines. For example, /dev/cua0
is associated with a 300 baud modem line, /dev/cul0, while /dev/cua1 is
associated with a 1200 baud modem line, /dev/cul1. For devices such as
the Quadracall which simulate multiple DN-11 units, the minor device
indicates which outgoing modem to use.
/dev/cua? call units
/dev/cul? associated modem lines
Two error numbers are of interest at open time.
[EBUSY] The dialer is in use.
[ENXIO] The device doesn't exist, or there's no power to it.
A dn driver appeared in Version 6 AT&T UNIX.
NetBSD 9.0 June 5, 1993 NetBSD 9.0