- NetBSD Manual Pages
DMZ(4) NetBSD/vax Kernel Interfaces Manual DMZ(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dmz -- DMZ-32 serial terminal multiplexor
dmz0 at uba? csr 0160540 vector dmzrinta dmzxinta dmzrintb dmzxintb
NOTE: This driver has not been ported from 4.4BSD yet.
The dmz device provides 24 lines of asynchronous serial line support.
Modem control on all ports is available as an option for the H3014 dis-
An optional argument flags may be supplied with the device specification
for dmz in the config file indicating that the line corresponding to bit
number i is not properly connected, and should be treated as hard-wired
with carrier always present. Thus specifying `flags 0x000004' for dmz0
would cause line ttya2 to be treated in this way.
Normal I/O control parameters for individual lines are managed by
ioctl(2) calls. Line speeds (there are 16 choices for the DMZ) may be
initiated via getty(8) and stty(1) or may be communicated by other pro-
grams which use ioctl(2) such as ifconfig(8), see tty(4).
The dmz driver normally enables the input silos with a short timeout (30
milliseconds); this allows multiple characters to be received per inter-
rupt during periods of high-speed input.
dmz%d: NXM line %d. No response from the UNIBUS on a DMA transfer within
a timeout period. This is often followed by a UNIBUS adapter error.
This occurs most frequently when the UNIBUS is heavily loaded and when
devices which hog the bus (such as RK07s) are present. It is not seri-
dmz%d: silo overflow. The character input silo overflowed before it
could be serviced. This can happen if a hard error occurs when the CPU
is running with elevated priority, as the system will then print a mes-
sage on the console with interrupts disabled. It is not serious.
The dmz driver appeared in 4.3BSD.
It should be possible to set the silo timeout with a configuration file
option, as the value is a trade-off between efficiency and response time
for flow control and character echo.
NetBSD 9.0 June 5, 1993 NetBSD 9.0