- NetBSD Manual Pages
ULPT(4) NetBSD Kernel Interfaces Manual ULPT(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ulpt -- USB printer support
ulpt* at uhub?
The ulpt driver provides support for Universal Serial Bus (USB) printers
that follow either the USB printer uni-directional or bi-directional pro-
Additional bits OR-ed in the minor device number with the unit number
select various features of the driver:
Minor Bit Function
0x40 Do not initialize (reset) the device on the port.
Some printers cannot handle the reset on open; in case of problems try
the ulpn device.
/dev/ulpt? USB printer with reset on open
/dev/ulpn? USB printer without reset on open
USB Device Class Definition for Printing Devices, USB Implementors Forum,
http://www.usb.org/developers/devclass_docs/usbprint11.pdf, January 2000.
The ulpt driver appeared in NetBSD 1.4.
NetBSD 9.0 May 16, 2009 NetBSD 9.0