- NetBSD Manual Pages
TPROF(4) NetBSD Kernel Interfaces Manual TPROF(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
tprof -- a sampling based profiler
The tprof driver provides kernel services necessary for tprof(8).
Specifically, it makes its backend driver collect profiling samples and
provide them to the userland consumer.
The API/ABI is currently undocumented and will likely change in future
without keeping compatibility.
On x86, the tprof_x86 module must be loaded in addition to the tprof
The tprof driver was written by YAMAMOTO Takashi.
There is no way to configure multiple backend drivers statically.
NetBSD 9.0 December 12, 2018 NetBSD 9.0