- NetBSD Manual Pages
SPRAY(8) NetBSD System Manager's Manual SPRAY(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
spray -- send many packets to host
spray [-c count] [-d delay] [-l length] host ...
spray sends multiple RPC packets to host and records how many of them
were correctly received and how long it took.
The options are as follows:
Send count packets.
Pause delay microseconds between sending each packet.
Set the length of the packet that holds the RPC call message to
length bytes. Not all values of length are possible because RPC
data is encoded using XDR. spray rounds up to the nearest possi-
spray is intended for use in network testing, measurement, and manage-
ment. This command can be very hard on a network and should be used with
netstat(1), ifconfig(8), ping(8), rpc.sprayd(8)
NetBSD 9.0 July 10, 1995 NetBSD 9.0