- NetBSD Manual Pages
PMU(4) NetBSD Kernel Interfaces Manual PMU(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pmu -- support for Power Management Units found in all Apple laptops and
some desktop Power Macintosh computers
pmu* at obio?
nadb* at pmu?
battery* at pmu?
smartbat* at pmu?
The pmu driver provides support for the Power Management Unit found in
Apple laptops and some desktop Power Macintosh computers. Functions con-
trolled by the PMU include the real time clock, ADB, power, batteries, on
some laptops like the PowerBook 3400c and similar machines it also con-
trols hotkeys and display brightness, on others it provides an iic(9) bus
and on some it controls CPU speed. On many older machines it also pro-
vides access to some non-volatile memory and thermal sensors. Not all
those features are present on all machines, for instance Power Macintosh
G4 and later machines don't have ADB, many more recent laptops have dis-
play brightness and backlight control built into the graphics controller
instead of the PMU, only a few older PowerBooks use the PMU for CPU speed
control and newer machines use a different way to access non-volatile
memory. However, all known PMUs so far provide a real time clock and
Notes by model
Real time clock and power control are present and supported on all
machines that can run NetBSD/macppc, ADB is supported when present.
PowerBook 2400, 3400c, and 3500
Battery status and thermal sensors found on the mainboard
and in the battery pack are supported by the battery(4)
driver, values can be read via envsys(4). Hotkeys for
brightness control are supported, CPU speed control and
parameter RAM are present but unsupported.
Power Macintosh G4
ADB is not present, iic(9) is present but unsupported.
battery(4), cuda(4), nadb(4), nvram(4), obio(4), iic(9)
Some features are currently unsupported, like the iic(9) bus, access to
parameter RAM and CPU speed control.
NetBSD 9.0 May 14, 2007 NetBSD 9.0