- NetBSD Manual Pages
WSKBD(4) NetBSD Kernel Interfaces Manual WSKBD(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
wskbd -- generic keyboard support in wscons
wskbd* at pckbd? console ? mux 1
(standard PC keyboard)
wskbd* at ukbd? console ? mux 1
wskbd* at lkkbd? console ? mux 1
(DEC LK200/400 serial keyboard)
wskbd0 at akbd? console ? mux 1
(Apple ADB keyboard)
wskbd0 at nextkbd? console ? mux 1
wskbd* at vrkiu? console ? mux 1
(NEC VR4000 series HPC keyboard)
wskbd* at skbd? console ? mux 1
(keyboard of misc hpcmips handheld devices)
wskbd* at btkbd? console ? mux 1
The wskbd driver handles common tasks for keyboards within the wscons(4)
framework. It is attached to the hardware specific keyboard drivers and
provides their connection to ``wsdisplay'' devices and a character device
The common keyboard support consists of:
· Mapping from keycodes (defined by the specific keyboard driver) to
keysyms (hardware independent, defined in
· Handling of ``compose'' sequences. Characters commonly not present
as separate key on keyboards can be generated after either a special
``compose'' key is pressed or a ``dead accent'' character is used.
· Certain translations, like turning an ``ALT'' modifier into an
· Automatic key repetition (``typematic'').
· Parameter handling for ``keyboard bells''.
· Generation of ``keyboard events'' for use by X servers.
The wskbd driver provides a number of ioctl functions to control key maps
and other parameters. These functions are accessible though the associ-
ated ``wsdisplay'' device as well. A complete list is in
/usr/include/dev/wscons/wsconsio.h. The wsconsctl(8) utility allows to
access key maps and other variables.
The console locator in the configuration line refers to the device's use
as input part of the operating system console. A device specification
containing a positive value here will only match if the device is in use
as system console. (The console device selection in early system startup
is not influenced.) This way, the console device can be connected to a
known wskbd device instance.
The following ioctl(2) calls are provided by the wskbd driver or by
devices which use it. Their definitions are found in
Get the keyboard type.
WSKBDIO_COMPLEXBELL, WSKBDIO_SETBELL, WSKBDIO_GETBELL,
WSKBDIO_SETDEFAULTBELL, WSKBDIO_GETDEFAULTBELL (struct
Get and set keyboard bell settings.
WSKBDIO_SETKEYREPEAT, WSKBDIO_GETKEYREPEAT, WSKBDIO_SETDEFAULTKEYREPEAT,
WSKBDIO_GETDEFAULTKEYREPEAT (struct wskbd_keyrepeat_data)
Get and set keyboard autorepeat settings.
WSKBDIO_SETLEDS, WSKBDIO_GETLEDS (int)
Get and set keyboard LED settings.
WSKBDIO_GETMAP, WSKBDIO_SETMAP (struct wskbd_map_data)
Get and set keyboard keymapping settings.
WSKBDIO_GETENCODING, WSKBDIO_SETENCODING (kbd_t)
Get and set keyboard encoding settings.
WSKBDIO_GETKEYCLICK, WSKBDIO_SETKEYCLICK (int)
Get and set keyboard keyclick settings.
Set the wscons_event protocol version. The default is 0
for binary compatibility. The latest version is always
available as WSKBD_EVENT_VERSION, and is currently 1. All
new code should use a call similar to the below to ensure
the correct version is returned.
int ver = WSKBD_EVENT_VERSION;
if (ioctl(fd, WSKBDIO_SETVERSION, &ver) == -1)
err(EXIT_FAILURE, "cannot set version");
btkbd(4), pckbd(4), ukbd(4), wscons(4), wsmux(4), wsconsctl(8), wskbd(9)
NetBSD 9.0 May 27, 2012 NetBSD 9.0