- NetBSD Manual Pages
STUIRDA(4) NetBSD Kernel Interfaces Manual STUIRDA(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
stuirda -- Sigmaltel 4116/4220 USB-IrDA bridge support
stuirda* at uhub?
irframe* at uirda?
The stuirda driver provides support for SigmaTels USB-IrDA bridges that
nearly follow the bridge specification:
Access to the IrDA device is through the irframe(4) driver. Before
accessing it, a firmware patch must be downloaded. At the time of writ-
ing this, it can be found at:
Unpack the archive with
tar -C /libdata/firmware/stuirda/ -xzf
The stuirda driver appeared in NetBSD 5.0.
stuirda needs the firmware for configuration, so it can't be loaded at
kernel startup time. As a workaround, you can plug in the USB-IrDA-
bridge after booting.
NetBSD 9.0 October 13, 2008 NetBSD 9.0