- NetBSD Manual Pages
PUFFS(4) NetBSD Kernel Interfaces Manual PUFFS(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
puffs -- Pass-to-Userspace Framework File System
puffs provides a framework for creating file systems as userspace
servers. The in-kernel VFS attachment is controlled through a special
device node, /dev/puffs. People looking to implement file systems should
use the system through the convenience library described in puffs(3).
A puffs file system can be unmounted regularly using umount(8). The file
system will automatically be unmounted in case the userspace server is
killed or the control file descriptor closed.
An unsupported experimental version of puffs first appeared in
NetBSD 4.0. A stable version appeared in NetBSD 5.0.
Antti Kantee <firstname.lastname@example.org>
NetBSD 9.0 November 22, 2009 NetBSD 9.0