- NetBSD Manual Pages
CCD.CONF(5) NetBSD File Formats Manual CCD.CONF(5)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ccd.conf -- concatenated disk driver configuration file
The ccd.conf file defines the configuration of concatenated disk devices,
or ccds. It is used by ccdconfig(8) when invoked with the -C option and
at system boot time. For more information about the concatenated disk
driver, see ccd(4).
Each line of the configuration file contains arguments as per the -c
argument to ccdconfig(8):
ccd ileave [flags] dev [...]
ccd The name of the ccd.
ileave The interleave, expressed in units of DEV_BSIZE. For serial
concatenation, specify `0'.
flags The flags for the device, which may be represented as a deci-
mal number, a hexadecimal number, a comma-separated list of
strings, or the word ``none''.
dev [...] The component partitions to be concatenated, which should be
of type FS_CCD.
A `#' is a comment, and everything to end of line is ignored. A `\' at
the end of a line indicates that the next line should be concatenated
with the current. A `\' preceding any character (other than the end of
line) prevents that character's special meaning from taking effect.
An example /etc/ccd.conf:
# Configuration file for concatenated disk devices
# ccd ileave flags component devices
ccd0 16 none /dev/sd2e /dev/sd3e
The ccd.conf configuration file first appeared in NetBSD 1.1.
NetBSD 9.0 August 13, 2014 NetBSD 9.0