- NetBSD Manual Pages
ATH(4) NetBSD Kernel Interfaces Manual ATH(4)
Powered by man-cgi 1.15, Panagiotis Christias
ath -- Atheros IEEE 802.11 driver
ath* at pci? dev ? function ?
ath* at cardbus? function ?
The ath driver provides support for wireless network adapters based on
the Atheros AR2413, AR2417, AR5210, AR5211, AR5212, AR5213, AR5413,
AR5416, AR5424, AR9160, AR9280, and AR9285 chips. Chip-specific support
is provided by the Atheros Hardware Access Layer (HAL).
Supported features include 802.11 and 802.3 frames, power management,
BSS, IBSS, and host-based access point operation modes. All host/device
interaction is via DMA.
The ath driver encapsulates all IP and ARP traffic as 802.11 frames, how-
ever it can receive either 802.11 or 802.3 frames. Transmit speed and
operating mode is selectable depending on your hardware.
AR5210-based devices support 802.11a operation with transmit speeds of 6
Mbps, 9 Mbps, 12 Mbps, 18 Mbps, 24 Mbps, 36 Mbps, 48 Mbps, and 54 Mbps.
AR5211-based devices support 802.11a and 802.11b operation with transmit
speeds as above for 802.11a operation and 1Mbps, 2Mbps, 5.5 Mbps and
11Mbps for 802.11b operation.
AR5212-based and AR5213-based devices support 802.11a, 802.11b, and
802.11g operation with transmit speeds appropriate to each.
All chips also support an Atheros Turbo Mode (TM) that operates in the
802.11a frequency range with 2x the transmit speeds. (This mode is, how-
ever, only interoperable with other Atheros-based devices.)
The actual transmit speed used is dependent on signal quality and the
``rate control'' algorithm employed by the driver. All chips support WEP
By default, the ath driver configures the card for BSS operation (aka in-
frastructure mode). This mode requires the use of an access point (base
The ath driver also supports the standard IBSS point-to-point mode where
stations can communicate amongst themselves without the aid of an access
The driver may also be configured to operate in hostap mode. In this
mode a host may function as an access point (base station). Access
points are different than operating in IBSS mode. They operate in BSS
mode. They allow for easier roaming and bridge all Ethernet traffic such
that machines connected via an access point appear to be on the local
The mode of operation is chosen by specifying the appropriate mediaopt
value to ifconfig. The -m flag to ifconfig will list the available
For more information on configuring this device, see ifconfig(8).
Devices supported by the ath driver come in either CardBus or mini-PCI
packages. Wireless cards in CardBus slots may be inserted and ejected on
The following cards are among those supported by the ath driver:
Card Chip Bus Standard
3Com 3CRPAG175 AR5212 CardBus a/b/g
Airlink AWLH4030 AR5212 PCI b/g
Aztech WL830PC AR5212 CardBus b/g
Belkin F6D3000 AR5212 PCI a/b/g
D-Link DWL-A520 AR5210 PCI a
D-Link DWL-A650 AR5210 CardBus a
D-Link DWL-AB650 AR5211 CardBus a/b
D-Link DWL-AG520 AR5212 PCI a/b/g
D-Link DWL-AG650 AR5212 CardBus a/b/g
D-Link DWL-AG660 AR521? CardBus a/b/g
D-Link DWL-G520 AR5212 PCI b/g
D-Link DWL-G650B AR5212 CardBus b/g
Elecom LD-WL54 AR5211 CardBus a
Elecom LD-WL54AG AR5212 CardBus a/b/g
Fujitsu E5454 AR5212 CardBus a/b/g
Fujitsu E5454 AR5212 CardBus a/b/g
Fujitsu FMV-JW481 AR5212 CardBus a/b/g
HP NC4000 AR5212 PCI a/b/g
I/O Data WN-A54 AR5212 CardBus a
I/O Data WN-AB AR5212 CardBus a/b
I/O Data WN-AG AR5212 CardBus a/b/g
Linksys WMP55AG AR5212 PCI a/b/g
Linksys WPC51AB AR5211 CardBus a/b
Linksys WPC55AG AR5212 CardBus a/b/g
NEC PA-WL/54AG AR5212 CardBus a/b/g
Netgear WAB501 AR5211 CardBus a/b
Netgear WAG311 AR5212 PCI a/b/g
Netgear WAG511 AR5212 CardBus a/b/g
Netgear WG311 AR5212 PCI b/g
Netgear WG511T AR5212 CardBus b/g
Orinoco 8470WD AR5212 CardBus a/b/g
Orinoco 8480 AR5212 CardBus a/b/g
Planex GW-NS54AG AR5212 CardBus a/b/g
Proxim Skyline 4030 AR5210 CardBus a
Proxim Skyline 4032 AR5210 PCI a
Samsung SWL-5200N AR5212 CardBus a/b/g
SMC SMC2735W AR5210 CardBus a
Sony PCWA-C300S AR5212 CardBus b/g
Sony PCWA-C500 AR5210 CardBus a
Sony PCWA-C700 AR5212 CardBus a/b
Ubiquiti SRC AR5213 CardBus a/b/g
ath%d: unable to attach hardware; HAL status %u The Atheros Hardware
Access Layer was unable to configure the hardware as requested. The sta-
tus code is explained in the HAL include file
ath%d: failed to allocate descriptors: %d The driver was unable to allo-
cate contiguous memory for the transmit and receive descriptors. This
usually indicates system memory is scarce and/or fragmented.
ath%d: unable to setup a data xmit queue! The request to the HAL to set-
up the transmit queue for normal data frames failed. This should not
ath%d: unable to setup a beacon xmit queue! The request to the HAL to
setup the transmit queue for 802.11 beacon frames failed. This should
ath%d: 802.11 address: %s The MAC address programmed in the EEPROM is
ath%d: hardware error; resetting An unrecoverable error in the hardware
occurred. Errors of this sort include unrecoverable DMA errors. The
driver will reset the hardware and continue.
ath%d: rx FIFO overrun; resetting The receive FIFO in the hardware over-
flowed before the data could be transferred to the host. This typically
occurs because the hardware ran short of receive descriptors and had no
place to transfer received data. The driver will reset the hardware and
ath%d: unable to reset hardware; hal status %u The Atheros Hardware
Access Layer was unable to reset the hardware as requested. The status
code is explained in the HAL include file
sys/external/isc/atheros_hal/dist/ah.h. This should not happen.
ath%d: unable to start recv logic The driver was unable to restart frame
reception. This should not happen.
ath%d: device timeout A frame dispatched to the hardware for transmis-
sion did not complete in time. The driver will reset the hardware and
continue. This should not happen.
ath%d: bogus xmit rate 0x%x An invalid transmit rate was specified for
an outgoing frame. The frame is discarded. This should not happen.
ath%d: ath_chan_set: unable to reset channel %u (%u MHz) The Atheros
Hardware Access Layer was unable to reset the hardware when switching
channels during scanning. This should not happen.
ath%d: unable to allocate channel table The driver was unable to allo-
cate memory for the table used to hold the set of available channels.
ath%d: unable to collect channel list from hal A problem occurred while
querying the HAL to find the set of available channels for the device.
This should not happen.
ath%d: %s: %dM -> %dM (%d ok, %d err, %d retr) The driver's rate control
algorithm changed the current rate for transmitting frames. This message
is temporarily enabled for normal use to help in diagnosing and improving
the rate control algorithm. The message indicates the new and old trans-
mit rates and the statistics it used to decide on this change.
ath%d: failed to enable memory mapping The driver was unable to enable
memory-mapped I/O to the PCI device registers. This should not happen.
ath%d: failed to enable bus mastering The driver was unable to enable
the device as a PCI bus master for doing DMA. This should not happen.
ath%d: cannot map register space The driver was unable to map the device
registers into the host address space. This should not happen.
ath%d: could not map interrupt The driver was unable to allocate an IRQ
for the device interrupt. This should not happen.
ath%d: could not establish interrupt The driver was unable to install
the device interrupt handler. This should not happen.
arp(4), cardbus(4), ifmedia(4), netintro(4), pci(4), ifconfig(8)
The ath device driver first appeared in FreeBSD 5.2. It was ported to
The ath driver was originally written by Sam Leffler, and was ported to
NetBSD by David Young.
Different regulatory domains have different default channels for adhoc
mode. See ifconfig(8) for information on how to change the channel.
Different regulatory domains may not be able to communicate with each
other with 802.11a as different regulatory domains do not necessarily
have overlapping channels.
Revision A1 of the D-LINK DWL-G520 and DWL-G650 are based on an Intersil
PrismGT chip and are not supported by this driver.
Revision v2 of the Netgear WG311 is based on a Texas Instruments ACX111
and is not supported by this driver.
Revision v3 of the Netgear WG311 is based on a Marvell Libertas 88W8335
and is not supported by this driver.
Performance in lossy environments is suboptimal. The algorithm used to
select the rate for transmitted packets is very simplistic. There is no
software retransmit; only hardware retransmit is used. Contributors are
encouraged to replace the existing rate control algorithm with a better
one (hint: all the information needed is available to the driver).
The driver does not fully enable power-save operation of the chip; conse-
quently power use is suboptimal.
NetBSD 9.0 May 27, 2019 NetBSD 9.0
Modified for NetBSD
by Kimmo Suominen