- NetBSD Manual Pages
INTRO(4) NetBSD/hp300 Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to hp300 special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
HP DEVICE SUPPORT
This section describes the hardware supported on the HP 9000/300 series.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in hp300/autoconf(4).
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Pseudo-devices are not listed. Devices are indicated by their functional
interface. Occasionally, new devices of a similar type may be added sim-
ply by creating appropriate table entries in the driver; for example, new
com serial interfaces (98644, 98626, and built-in apci and
ct 7946/9144 CS/80 cartridge tape
dcm HP 98642A communications multiplexer
dio DIO/DIO-II bus
dnkbd Domain keyboard
dvbox HP98730 ``DaVinci'' device interface
fhpib ``fast'' HP-IB interface
frodo Frodo ASIC (a.k.a. Apollo Utility Chip)
gbox HP98700 ``Gatorbox'' device interface
grf/ite Topcat/Gatorbox/Renaissance frame buffer
hil HIL interface
nhpib Built-in and 98625 HP-IB interface
hyper Hyperion device interface
intio HP300 internal I/O space driver
ite HP Internal Terminal Emulator
le 98643 Lance-based Ethernet interface
ppi HP-IB printer/plotter interface
rbox HP98720 ``Renaissance'' device interface
rd CS/80 disk interface
rmp HP Remote Maintenance Protocol family
spc HP98265A SCSI interface
topcat HP98544-98550 ``Topcat'' and ``Catseye'' device
Building 4.3 BSD UNIX Systems with Config (SMM:2).
The HP300 intro appeared in 4.3BSD-Reno.
NetBSD 9.0 February 17, 2017 NetBSD 9.0