- NetBSD Manual Pages
BOOT(8) NetBSD/hp300 System Manager's Manual BOOT(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
boot -- system bootstrapping procedures
Power fail and crash recovery
Normally, the system will reboot itself at power-up or after crashes. An
automatic consistency check of the file systems will be performed, and
unless this fails, the system will resume multi-user operations.
On an HP300, the boot procedure uses the boot ROM to load a boot program
from an LIF format directory at the beginning of an attached disk. The
/usr/mdec directory contains a disk boot programs which should be placed
in a new pack automatically by newfs(8) when the ``a'' partition file
system on the pack is created.
This boot program finds the corresponding file on the given device
(netbsd by default), loads that file into memory, and starts the program
at the entry address specified in the program header.
The boot program can be interrupted by typing `^C' (ctrl-C). This will
force the boot program to interactively prompt for a system to boot. If
not interrupted, it will boot from the device from which the boot program
itself was loaded.
The file specifications used for an interactive boot are of the form:
where device is the type of the device to be searched, unit is 8 * the
HP-IB number plus the unit number of the disk or tape, and minor is the
disk partition or tape file number. Normal line editing characters can
be used when typing the file specification. Currently, ``rd'' and ``sd''
are the only valid device specifiers.
For example, to boot from the `a' file system of unit 0 on HP-IB 2, type
`rd(16, 0)netbsd' to the boot prompt. For tapes, the minor device number
gives a file offset.
In an emergency, the bootstrap methods described in the paper Installing
4.3bsd on the HP300 can be used to boot from a distribution tape.
/netbsd system code
/usr/mdec/bootrd LIF format boot block
/usr/mdec/installboot program to install boot blocks
halt(8), reboot(8), shutdown(8)
NetBSD 9.0 April 19, 1994 NetBSD 9.0