- NetBSD Manual Pages
AUTOCONF(4) NetBSD/hp300 Kernel Interfaces Manual AUTOCONF(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
autoconf -- diagnostics from the autoconfiguration code
When NetBSD bootstraps it probes the innards of the machine on which it
is running and locates controllers, drives, and other devices, printing
out what it finds on the console. This procedure is driven by a system
configuration table which is processed by config(1) and compiled into
Autoconfiguration on the HP300s is similar to that on the VAX, the pri-
mary difference is in the naming conventions. On the HP300, if devices
exist which are not configured they will be ignored; if devices exist of
unsupported type they will be ignored.
Normally, the system uses the disk from which it was loaded as the root
filesystem. If that is not possible, a generic system will use `rd0' if
it exists. If such a system is booted with the RB_ASKNAME option (see
reboot(2)), then the name of the root device is read from the console
terminal at boot time, and any available device may be used.
CPU type not configured. You tried to boot NetBSD on a CPU type which it
doesn't (or at least this compiled version of NetBSD doesn't) understand.
hpibbus%d at sc%d, ipl %d. An HP-IB was found at sc%d (the select code)
with ipl%d (interrupt priority level). NetBSD will call it hpibbus%d.
%s%d at hpibbus%d, slave %d. An HP-IB disk or tape controller was found.
For disks `%s%d' will look like `rd0', for tapes like `ct0'. The `%s' in
the first line will be a product type like ``7945A'' or ``9144''. The
slave number comes from the address select switches on the drive.
grf0 csr 0x560000
grf%d at sc%d A bit mapped display was found either at the ``internal''
address (first case) or at some ``external'' select code (second case).
If it exists, the internal display will always be unit 0.
%s%d at sc%d, ipl %d flags %d Another peripheral controller was found at
the indicated select code and with indicated interrupt priority level.
`%s' will be one of com(4) (single-port serial interfaces), hp300/dcm(4)
(four-port serial interfaces), or le(4) (LAN cards). The slave number
comes from the address select switches on the interface card.
config(1), hp300/intro(4), boot(8)
4.3BSD for the HP300, in the distribution documentation package.
NetBSD 9.0 February 17, 2017 NetBSD 9.0