extattr(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
EXTATTR(9)             NetBSD Kernel Developer's Manual             EXTATTR(9)


NAME
extattr -- file system extended attributes
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/extattr.h>
DESCRIPTION
Extended attributes allow additional meta-data to be associated with vnodes representing files and directories. The semantics of this addi- tional data is that of a ``name=value'' pair, where a name may be defined or undefined, and if defined, associated with zero or more bytes of arbi- trary binary data. Extended attribute names exist within a set of names- paces; each operation on an extended attribute is required to provide the namespace to which the operation refers. If the same name is present in multiple namespaces, the extended attributes associated with the names are stored and manipulated independently. The following two namespaces are defined universally, although individual file systems may implement additional namespaces, or not implement these namespaces: EXTATTR_NAMESPACE_USER, EXTATTR_NAMESPACE_SYSTEM. The semantics of these attributes are intended to be as follows: user attribute data is pro- tected according the normal discretionary and mandatory protections asso- ciated with the data in the file or directory; system attribute data is protected such that appropriate privilege is required to directly access or manipulate these attributes. Reads of extended attribute data may return specific contiguous regions of the meta-data, in the style of VOP_READ(9), but writes will replace the entire current ``value'' associated with a given name. As there are a plethora of file systems with differing extended attributes, availabil- ity and functionality of these functions may be limited, and they should be used with awareness of the underlying semantics of the supporting file system. Authorization schemes for extended attribute data may also vary by file system, as well as maximum attribute size, and whether or not any or specific new attributes may be defined. Extended attributes are named using a nul-terminated character string. Depending on underlying file system semantics, this name may or may not be case-sensitive. Appropriate vnode extended attribute calls are: VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9), and VOP_SETEXTATTR(9).
SEE ALSO
vfsops(9), vnodeops(9) NetBSD 9.0 January 2, 2005 NetBSD 9.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.