- NetBSD Manual Pages
BWI(4) NetBSD Kernel Interfaces Manual BWI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
bwi -- Broadcom BCM430x/4318 IEEE 802.11b/g wireless network driver
bwi* at pci? dev ? function ?
bwi* at cardbus? function ?
The bwi driver provides support for Broadcom BCM430x/4318 wireless net-
work adapters. For more information on configuring this device, see
The following per-interface variables are implemented in the hw.bwiX
branch of the sysctl(3) MIB.
debug Debug flags.
dwell_time Channel dwell time during scan (msec).
fw_version Firmware version.
led_idle Number of ticks before LED enters idle state.
led_blink Allow LED to blink.
txpwr_calib Enable software TX power calibration.
The following cards are among those supported by the bwi driver:
Card Chip Bus Standard
Buffalo WLI-CB-G54 BCM4306 CardBus b/g
Buffalo WLI3-CB-G54L BCM4318 CardBus b/g
Buffalo WLI-PCI-G54S BCM4306 PCI b/g
Dell Wireless 1370 BCM4318 Mini PCI b/g
Dell Wireless 1470 BCM4318 Mini PCI b/g
Dell Truemobile 1400 BCM4309 Mini PCI b/g
Dell Latitude D505 BCM4306 PCI b/g
Apple AirPort Extreme b/g
The firmware for the adapter is not shipped with NetBSD and must be
obtained separately. An archive with firmware files that are known to
work can be found at:
The firmware files conventionally reside in /libdata/firmware/bwi and
will be loaded when the interface is brought up. Note: the v3 subdirec-
tory in the above firmware archive should exist in the firmware folder.
The full list of paths checked for firmware can be found in the
hw.firmware.path sysctl(3) node.
arp(4), cardbus(4), ifmedia(4), pci(4), ifconfig(8), sysctl(8),
The bwi driver first appeared in NetBSD 6.0.
The bwi driver was written by Sepherosa Ziehau for Dragonfly BSD. It was
ported to NetBSD by Taylor R. Campbell <riastradh@NetBSD.org>.
The hardware specification was reverse engineered by the people at
Thanks go also to johill and mb on the #bcm-specs channel.
BCM4306 and BCM4309 chips do not work properly on channel 1, 2, and 3.
NetBSD 9.0 April 25, 2012 NetBSD 9.0