- NetBSD Manual Pages
FDC(4) NetBSD/amiga Kernel Interfaces Manual FDC(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
fdc -- Amiga custom chip floppy disk controller device
fdc0 at mainbus0
fd* at fdc? unit ?
The fdc device driver provides support for the mainboard floppy disk con-
troller and floppy disk drives on Amiga systems.
The driver supports the following floppy diskette formats by using par-
880KB 3.5-inch 11 sectors/track (``Amiga'') (a)
1.76MB 3.5-inch 22 sectors/track (``Amiga'') (a)
880KB 5.25-inch 11 sectors/track (``Amiga'') (a)
720KB 3.5-inch 9 sectors/track (``MS-DOS'') (b)
1.44MB 3.5-inch 18 sectors/track (``MS-DOS'') (b)
720KB 5.25-inch 9 sectors/track (``MS-DOS'') (b)
On systems equipped with floppy disk drives capable of using high-density
floppy diskettes, the driver automatically detects whether the inserted
floppy diskette is either a double-density or a high-density medium.
fdc: unable to allocate DMA buffer The driver found the controller, but
was unable to allocate the amount of chip memory required for its DMA
In order to detect a floppy disk drive's capability of using high-density
media, a high-density diskette has to be inserted for the duration of the
autoconfiguration phase of the drive.
The fdc driver supports neither the fdformat(1) facility nor the
NetBSD 9.0 February 17, 2017 NetBSD 9.0