- NetBSD Manual Pages
DZ(4) NetBSD/vax Kernel Interfaces Manual DZ(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dz -- DZ-11 serial multiplexer device interface
dz0 at uba0 csr 0160100 vector dzrint dzxint
A DZ-11 provides 8 communication lines with partial modem control, ade-
quate for UNIX dialup use.
An optional argument flags may be supplied with the device specification
in the config file indicating that the line corresponding to bit number i
is not properly connected, and should be treated as hard-wired with car-
rier always present. Thus specifying `flags 0x04' for dz0 would cause
line tty02 to be treated in this way.
Normal I/O control parameters for individual lines are managed by
ioctl(2) calls. Line speeds may be initiated via the ttys(5) file,
stty(1) or ifconfig(8) to name a few, see tty(4).
The dz driver monitors the rate of input on each board, and switches
between the use of character-at-a-time interrupts and input silos. While
the silo is enabled during periods of high-speed input, the driver polls
for input 30 times per second.
dz%d: silo overflow . The 64 character input silo overflowed before it
could be serviced. This can happen if a hard error occurs when the CPU
is running with elevated priority, as the system will then print a mes-
sage on the console with interrupts disabled. It is not serious.
stty(1), tty(4), ttys(5), getty(8)
A dz driver appeared in Version 32V AT&T UNIX.
NetBSD 8.1 June 5, 1993 NetBSD 8.1