- NetBSD Manual Pages
RESCUE(8) NetBSD System Manager's Manual RESCUE(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rescue -- rescue utilities in /rescue
The /rescue directory contains a collection of common utilities intended
for use in recovering a badly damaged system. With the transition to a
dynamically-linked root beginning with NetBSD 2.0, there is a real possi-
bility that the standard tools in /bin and /sbin may become non-func-
tional due to a failed upgrade or a disk error. The tools in /rescue are
statically linked and should therefore be more resistant to damage. How-
ever, being statically linked, the tools in /rescue are also less func-
tional than the standard utilities. In particular, they do not have full
use of the locale, pam(3), and nsswitch libraries.
If your system fails to boot, and it shows an error message similar to:
init: not found
try booting the system with the boot flag ``-a'' and supplying
/rescue/init, which is the rescue init(8), as the init path.
If your system fails to boot, and it shows a prompt similar to:
Enter full pathname of shell or RETURN for /bin/sh:
the first thing to try running is the standard shell, /bin/sh. If that
fails, try running /rescue/sh, which is the rescue shell. To repair the
system, the root partition must first be remounted read-write. This can
be done with the following mount(8) command:
/rescue/mount -uw /
The next step is to double-check the contents of /bin, /lib, /libexec,
and /sbin, possibly mounting a NetBSD installation CD-ROM and copying
files from there. Once it is possible to successfully run /bin/sh,
/bin/ls, and other standard utilities, try rebooting back into the stan-
The /rescue tools are compiled using crunchgen(1), which makes them con-
siderably more compact than the standard utilities.
/rescue Root of the rescue hierarchy.
The rescue utilities first appeared in NetBSD 2.0.
The rescue system was written by Luke Mewburn <lukem@NetBSD.org>. This
manual page was written by Simon L. Nielsen <simon@FreeBSD.org>, based on
text by Tim Kientzle <kientzle@FreeBSD.org>.
NetBSD 8.1 April 5, 2012 NetBSD 8.1