- NetBSD Manual Pages
IRIP(4) NetBSD Kernel Interfaces Manual IRIP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
irip -- Raw IP over ISDN network driver
pseudo-device irip count
The irip driver interfaces the IP subsystem of the operating system with
the ISDN layer so that transport of IP packets over an ISDN link is pos-
The driver just packs IP packets without anything appended or prepended
into raw HDLC packets on the B channel and transfers them to a remote
site. IP packets received from the remote site are queued into the local
IP protocol stack.
The format of the resulting packet on the B channel is:
(HDLC opening flag) (IP-packet) (CRC) (HDLC closing flag)
In the case where an IP packet for a remote site arrives in the driver
and no connection has been established yet, the driver communicates with
the isdnd(8) daemon to establish a connection.
The driver has support for interfacing to the bpf(4) subsystem for using
tcpdump(8) with the irip interfaces.
The driver optionally (when compiled with the IRIP_VJ option) provides
Van Jacobson header compression, under control of the link0 and link1
options to ifconfig(8):
link0 Apply VJ compression to outgoing packets on this
interface, and assume that incoming packets
link1 Check incoming packets for Van Jacobson compres-
sion; if they appear to be compressed, automati-
cally set link0.
The default values are on for link1 and off for link0.
bpf(4), isdnd.rc(5), isdnd(8), tcpdump(8)
The irip device driver and this man page were written by Hellmuth
NetBSD 8.1 July 6, 1998 NetBSD 8.1