- NetBSD Manual Pages
SDTEMP(4) NetBSD Kernel Interfaces Manual SDTEMP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
sdtemp -- JEDEC JC-42.4 compatible memory module temperature sensors
sdtemp* at iic? addr 0x18
sdtemp* at iic? addr 0x19
sdtemp* at iic? addr 0x1a
sdtemp* at iic? addr 0x1b
sdtemp* at iic? addr 0x1c
sdtemp* at iic? addr 0x1d
sdtemp* at iic? addr 0x1e
sdtemp* at iic? addr 0x1f
The sdtemp driver provides support for the Microchip Technology
MCP9805/98242 and other chips that conform to JEDEC Standard 21-C section
4.7. Memory module temperature sensors are optional on DDR2 and newer
DIMMs. Sensors provided by this driver, including the on-chip thresholds
for the Alarm Window and Critical level, are accessed through the
The sdtemp supports temperature ranges from -256 to +255 degrees C.
Chips supported by the sdtemp driver include TSE2004av compliant devices
· Analog Devices ADT7408
· Atmel AT30TS00 and AT30TSE004
· On semiconductor (Catalyst) CAT34TS02, CAT34TS02C, CAT34TS04
· Giantec Semiconductor GT30TS00 and GT34TS02
· Integrated Deviced Technology TSE2002B3, TSE2002GB2,
TSE2004GB2, TS3000B3, TS3000GB0, TS3000GB2, and TS30001GB2
· Maxim MAX6604
· Microchip Technology EMC1501, MCP9804, MCP9805, MCP9843,
MCP98242, MCP98243, and MCP98244
· NXP Semiconductors SE97 and SE98
· STmicroelectronics STTS424, STTS424E, STTS2002, STTS2004, and
The sdtemp device appeared in NetBSD 6.0.
Interrupt support is unimplemented.
NetBSD 8.1 February 22, 2018 NetBSD 8.1