- NetBSD Manual Pages
MICROTIME(9) NetBSD Kernel Developer's Manual MICROTIME(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime --
get the current time
bintime(struct bintime *bt);
getbintime(struct bintime *bt);
microtime(struct timeval *tv);
getmicrotime(struct timeval *tv);
nanotime(struct timespec *tsp);
getnanotime(struct timespec *tsp);
The bintime() and getbintime() functions store the system time as a
struct bintime at the addresses specified by bt. The microtime() and
getmicrotime() functions perform the same utility, but record the time as
a struct timeval instead. Similarly the nanotime() and getnanotime()
functions store the time as a struct timespec. The structures are
described in timeval(3).
The bintime(), microtime(), and nanotime() functions always query the
timecounter to return the current time as precisely as possible. Whereas
getbintime(), getmicrotime(), and getnanotime() functions are abstrac-
tions which return a less precise, but faster to obtain, time.
The intent of the getbintime(), getmicrotime(), and getnanotime() func-
tions is to enforce the user's preference for timer accuracy versus exe-
cution time. They should be used where a precision of 1/HZ (e.g., 10
msec on a 100HZ machine, see hz(9)) is acceptable or where performance is
The system realtime clock is guaranteed to be monotonically increasing at
all times. As such, all calls to these functions are guaranteed to
return a system time greater than or equal to the system time returned in
any previous calls. Comparable functions exist to retrieve the time
elapsed since boot; see microuptime(9).
The implementation of the microtime() family of functions is in
sys/kern/kern_tc.c as a part of the timecounter(9) framework.
The implementation of the time counter sources used by the timecounter(9)
is machine dependent, hence its location in the source code tree varies
from architecture to architecture.
settimeofday(2), bintime_add(9), inittodr(9), time_second(9), tvtohz(9)
This manual page was written by Jeremy Cooper and
Kelly Yancey <email@example.com>.
Despite the guarantee that the system realtime clock will always be mono-
tonically increasing, it is always possible for the system clock to be
manually reset by the system administrator to any date.
NetBSD 8.1 May 13, 2013 NetBSD 8.1