- NetBSD Manual Pages
UU(4) NetBSD/vax Kernel Interfaces Manual UU(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
uu -- TU-58/DECtape II UNIBUS cassette interface
uu0 at uba0 csr 0176500 vector uurintr uuxintr
NOTE: This driver has not been ported from 4.4BSD yet.
The uu device provides access to dual DEC TU-58 tape cartridge drives
connected to the UNIBUS via a DL-11W interface module.
The interface supports only block I/O to the TU-58 cassettes (see
physio(4)). The drives are normally manipulated with the arff(8) program
using the ``m'' and ``f'' options.
The driver provides for an optional write and verify (read after write)
mode that is activated by specifying the ``a'' device.
The TU-58 is treated as a single device by the system even though it has
two separate drives, `uu0' and `uu1'. If there is more than one TU-58
unit on a system, the extra drives are named `uu2', `uu3' etc.
Assembly language code to assist the driver in handling the receipt of
data (using a pseudo-DMA approach) should be included when using this
driver; specify `options UUDMA' in the configuration file.
uu%d: no bp, active %d. A transmission complete interrupt was received
with no outstanding I/O request. This indicates a hardware problem.
uu%d protocol error, state=%s, op=%x, cnt=%d, block=%d. The driver
entered an illegal state. The information printed indicates the illegal
state, the operation currently being executed, the I/O count, and the
block number on the cassette.
uu%d: break received, transfer restarted. The TU-58 was sending a con-
tinuous break signal and had to be reset. This may indicate a hardware
problem, but the driver will attempt to recover from the error.
uu%d receive state error, state=%s, byte=%x. The driver entered an ille-
gal state in the receiver finite state machine. The state is shown along
with the control byte of the received packet.
uu%d: read stalled. A timer watching the controller detected no inter-
rupt for an extended period while an operation was outstanding. This
usually indicates that one or more receiver interrupts were lost and the
transfer is restarted.
uu%d: hard error bn%d, pk_mod %o. The device returned a status code
indicating a hard error. The actual error code is shown in octal. No
retries are attempted by the driver.
The following errors may be returned:
[ENXIO] Nonexistent drive (on open); offset is too large or bad (unde-
fined) ioctl(2) code.
[EIO] Open failed, the device could not be reset.
[EBUSY] Drive in use.
The uu driver appeared in 4.2BSD.
NetBSD 8.0 February 17, 2017 NetBSD 8.0