- NetBSD Manual Pages
TPM(4) NetBSD Kernel Interfaces Manual TPM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
tpm -- Trusted Platform Module
tpm* at isa? iomem 0xfed40000
tpm* at isa? iomem 0xfed40000 irq 7
The tpm driver provides support for various trusted platform modules
(TPM) that can store cryptographic keys.
· Atmel 97SC3203
· Broadcom BCM0102
· Infineon IFX SLD 9630 TT 1.1 and IFX SLB 9635 TT 1.2
· Intel INTC0102
· Sinosun SNS SSX35
· STM ST19WP18
· Winbond WEC WPCT200
The driver can be configured to use an IRQ by providing a free ISA inter-
rupt vector using the keyword irq in the kernel configuration file or
using config(1). If not IRQ is specified, the driver uses polling. This
is the default configuration.
The tpm driver was written by Michael Shalayeff and Hans-Joerg Hoexer.
NetBSD 8.0 January 22, 2012 NetBSD 8.0