- NetBSD Manual Pages
RE(4) NetBSD Kernel Interfaces Manual RE(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
re -- RealTek 8139C+/8169/8169S/8168/8110S/8111 PCI Ethernet adapter
re* at pci? dev ? function ?
re* at cardbus? function ?
The re driver provides support for various NICs based on the RealTek
RTL8139C+, RTL8169, RTL8169S, RTL8168, and RTL8110S PCI/Cardbus Ethernet
controllers, including the following:
· Alloy Computer Products EtherGOLD 1439E 10/100 (8139C+)
· Compaq Evo N1015v Integrated Ethernet (8139C+)
· Gigabyte 7N400 Pro2 Integrated Gigabit Ethernet (8110S)
· NETGEAR GA311 (8169S)
· PLANEX COMMUNICATIONS Inc. GN-1200TC (8169S)
· Xterasys XN-152 10/100/1000 NIC (8169)
· Corega CG-LAPCIGT Gigabit Ethernet (8169S)
· D-Link DGE-528T Gigabit Ethernet (8169S)
· US Robotics (3Com) USR997902 Gigabit Ethernet (8169S)
· Linksys EG1032 rev. 3 Gigabit Ethernet (8169S)
NICs based on the 8139C+ are capable of 10 and 100Mbps speeds over CAT5
cable. NICs based on the 8169, 8169S, 8168, and 8110S are capable of 10,
100, and 1000Mbps operation.
All NICs supported by the re driver have TCP/IP checksum offload and
hardware VLAN tagging/insertion features, and use a descriptor-based DMA
mechanism. They are also capable of TCP large send (TCP segmentation
The 8139C+ is a single-chip solution combining both a 10/100 MAC and PHY,
and its PHY is supported by rlphy(4). The 8169 is a 10/100/1000 MAC
only, requiring a GMII or TBI external PHY and some 8169 based boards
have Marvell 88E1000 PHY supported by makphy(4). The 8169S and 8110S are
single-chip devices containing both a 10/100/1000 MAC and 10/100/1000
copper PHY, which is supported by rgephy(4). Standalone 10/100/1000
cards are available in both 32-bit PCI and 64-bit PCI models. The 8110S
is designed for embedded LAN-on-motherboard applications.
The 8169, 8169S, and 8110S also support jumbo frames, which can be con-
figured via the interface MTU setting. Selecting an MTU larger than 1500
bytes with the ifconfig(8) utility configures the adapter to receive and
transmit jumbo frames.
The re driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseTX Set 1000baseTX operation over twisted pair. The RealTek
GigE chips support 1000Mbps in full-duplex mode only.
The re driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
re%d: can't map i/o space A fatal initialization error has occurred.
re%d: can't map mem space A fatal initialization error has occurred.
re%d: couldn't map interrupt A fatal initialization error has occurred.
re%d: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
arp(4), cardbus(4), mii(4), netintro(4), pci(4), rgephy(4), rlphy(4),
RealTek Semiconductor RTL8139C+, RTL8169, RTL8169S, and RTL8110S
The re device driver first appeared in FreeBSD 5.2 and was ported to
The re driver was written by Bill Paul <email@example.com>.
The Xterasys XN-152 32-bit PCI NIC, which uses the RTL8169 MAC and Mar-
vell 88E1000 PHY, has a defect that causes DMA corruption if the board is
plugged into a 64-bit PCI slot. The defect lies in the board design, not
the chip itself: the PCI REQ64# and ACK64# lines should be pulled high,
but they are not. The result is that the 8169 chip is tricked into per-
forming 64-bit DMA transfers even though a 64-bit data path between the
NIC and the bus does not actually exist.
Unfortunately, it is not possible to correct this problem in software,
however it is possible to detect it. When the re driver is loaded, it
will run a diagnostic routine designed to validate DMA operation by plac-
ing the chip in digital loopback mode and initiating a packet transmis-
sion. If the card functions properly, the transmitted data will be
echoed back unmodified. If the echoed data is corrupt, the driver will
print an error message on the console and abort the device attach. The
user should ensure the NIC is installed in a 32-bit PCI slot to avoid
The RealTek 8169, 8169S, and 8110S chips appear to only be capable of
transmitting jumbo frames up to 7.5K in size.
NetBSD 8.0 April 6, 2013 NetBSD 8.0