- NetBSD Manual Pages
PAD(4) NetBSD Kernel Interfaces Manual PAD(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pad -- Pseudo audio device driver
audio* at audiobus?
pad is a pseudo-device driver which provides support for feeding back PCM
data from a consumer of the audio(4) API to userland.
The pad pseudo-device driver receives data from /dev/soundN and feeds the
raw PCM output to /dev/padN.
The following example streams an MP3 to an Apple AirTunes compatible
$ rtunes - < /dev/pad0 &
$ mpg123 -a /dev/sound1 mozart.mp3
The pad driver appeared in NetBSD 5.0.
Jared D. McNeill <firstname.lastname@example.org>
NetBSD 8.0 November 11, 2007 NetBSD 8.0