udp(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
UDP(4)                  NetBSD Kernel Interfaces Manual                 UDP(4)


NAME
udp -- Internet User Datagram Protocol
SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_DGRAM, 0); int socket(AF_INET6, SOCK_DGRAM, 0);
DESCRIPTION
UDP is a simple, unreliable datagram protocol which is used to support the SOCK_DGRAM abstraction for the Internet protocol family. UDP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be ``connected'' to a TCP port). In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved ``broadcast address''; this address is network interface dependent. There are two UDP-level setsockopt(2)/getsockopt(2) options. UDP_OPTIONS may be used to change the default behavior of the socket. For example: setsockopt(s, IPPROTO_UDP, UDP_OPTIONS, NULL, 0); The UDP_ENCAP option can be used to encapsulate ESP packets in UDP. There are two valid encapsulation options: UDP_ENCAP_ESPINUDP_NON_IKE from draft-ietf-ipsec-nat-t-ike-00/01 and UDP_ENCAP_ESPINUDP from draft- ietf-ipsec-udp-encaps-06 defined in <netinet/udp.h>. Options at the IP transport level may be used with UDP; see ip(4) or ip6(4).
DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been con- nected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a net- work address for which no network interface exists.
SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), inet(4), inet6(4), intro(4), ip(4), ip6(4), rfc6056(7), sysctl(7) User Datagram Protocol, RFC, 768, August 28, 1980. Requirements for Internet Hosts -- Communication Layers, RFC, 1122, October 1989.
HISTORY
The udp protocol appeared in 4.2BSD. NetBSD 8.0 June 20, 2012 NetBSD 8.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.