- NetBSD Manual Pages
BOOT(8) NetBSD System Manager's Manual BOOT(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
boot -- system bootstrapping procedures
The NetBSD kernel is started by placing it near the beginning of physical
memory and transferring to the entry point. Since the system is not
reenterable, it is necessary to read it in from disk or the network each
time it is to be bootstrapped.
Power fail and crash recovery
FPGA devices lose their content upon loss of power and must be re-pro-
grammed. This is usually accomplished via a JTAG cable programmer, or
using a FLASH device. Once the eMIPS processor has been programmed into
the FPGA, the system will normally boot itself. An automatic consistency
check of the file systems will be performed, and unless this fails, the
system will resume multi-user operations.
Xilinx XUP, ML401 and ML402
On these systems the kernel is normally read in from disk. The path used
for automatic booting is /netbsd, but it can be overridden in the
optional file /boot.config stored in the root of the disk filesystem. The
user can also type a different filename and a combination of boot
On this system there is no local disk and booting over the network is the
only option. Network boot can also be explicitly selected by hitting f
at the boot loader prompt.
At the boot loader prompt, the user may boot NetBSD with a number of
options that are passed to the kernel unmodified. Parsing of these
options is defined in the file /sys/boot_flag.h Some additional flags are
e Empty -- this argument requests NetBSD to ignore all symbolic
information and empty its initial symbol table.
n Name -- Prompt for the root file system device, the system
crash dump device, and the path to init(8).
N NoName -- Do not prompt for the root file system device, the
system crash dump device, and the path to init(8). If the
configured-in devices are present, use them.
s Single -- Boot only to single-user mode.
ddb(4), halt(8), init(8), installboot(8), rc(8), reboot(8), savecore(8),
The boot command is currently under development.
NetBSD 8.0 October 5, 2013 NetBSD 8.0