- NetBSD Manual Pages
AD(4) NetBSD/vax Kernel Interfaces Manual AD(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ad -- Data Translation A/D converter
ad0 at uba0 csr 0170400 vector adintr
NOTE: This driver has not been ported from 4.4BSD yet.
The ad driver provides an interface to the Data Translation A/D con-
verter. This is not a real-time driver, but merely allows the user
process to sample the board's channels one at a time. Each minor device
selects a different A/D board.
The driver communicates to a user process by means of ioctl(2)s. The
AD_CHAN ioctl(2) selects which channel of the board to read. For exam-
chan = 5;
ioctl(fd, AD_CHAN, &chan);
selects channel 5. The AD_READ ioctl(2) actually reads the data and
returns it to the user process. An example is
ioctl(fd, AD_READ, &data);
The ad driver appeared in 4.1BSD.
NetBSD 7.1.2 June 5, 1993 NetBSD 7.1.2