- NetBSD Manual Pages
USTIR(4) NetBSD Kernel Interfaces Manual USTIR(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ustir -- SigmaTel STIr4200-based USB-IrDA bridge support
ustir* at uhub?
irframe* at ustir?
The ustir driver provides support for USB-IrDA bridges based on the Sig-
maTel STIr4200. The driver is known to work with the following adapters:
Mars II 740 USB IrDA Adapter
Access to the IrDA device is through the irframe(4) driver.
irframe(4), uirda(4), usb(4)
The ustir driver appeared in NetBSD 1.6.
The ustir driver was written by David Sainty <David.Sainty@dtsp.co.nz>.
The STIr4200 cannot notify the driver when it has received data, instead
it has to be continuously polled. This driver polls (when idle) at a
fairly low rate of 10 times per second, which means that system perfor-
mance is not overly affected by rapid polling, but latency is fairly
NetBSD 7.1.2 December 24, 2001 NetBSD 7.1.2