- NetBSD Manual Pages
TRACEROUTE6(8) NetBSD System Manager's Manual TRACEROUTE6(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
traceroute6 -- print the route IPv6 packets will take to the destination
traceroute6 [-adIlnrv] [-A as_server] [-f firsthop] [-g gateway]
[-m hoplimit] [-p port] [-q probes] [-s src] [-w waittime]
-A Turn on AS# lookups and use the given server instead of the
-a Turn on AS# lookups for each hop encountered.
-d Debug mode.
Specify how many hops to skip in trace.
Specify intermediate gateway (traceroute6 uses routing header).
-I Use ICMP6 ECHO instead of UDP datagrams.
-l Print both host hostnames and numeric addresses. Normally
traceroute6 prints only hostnames if -n is not specified, and
only numeric addresses if -n is specified.
Specify maximum hoplimit.
-n Do not resolve numeric address to hostname.
Set UDP port number to port.
Set the number of probe per hop count to probes.
-r Bypass the normal routing tables and send directly to a host on
an attached network. If the host is not on a directly-attached
network, an error is returned. This option can be used to send
probes to a local host through an interface that has no route
through it (e.g., after the interface was dropped by route6d(8)).
-s src Src specifies the source IPv6 address to be used.
-v Be verbose.
Specify the delay time between probes.
The traceroute6 command exits 0 on success, and >0 on errors.
ping(8), ping6(8), traceroute(8)
The traceroute6 command first appeared in WIDE hydrangea IPv6 protocol
NetBSD 7.1.2 September 17, 2005 NetBSD 7.1.2