- NetBSD Manual Pages
STORE(9) NetBSD Kernel Developer's Manual STORE(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
store, subyte, suibyte, susword, suswintr, suword, suiword -- store data
subyte(void *base, int c);
susword(void *base, short c);
suswintr(void *base, short c);
suword(void *base, long c);
The store functions are designed to copy small amounts of data to the
user-space of the currently running process.
The store routines provide the following functionality:
subyte() Stores a byte of data to the user-space address base.
susword() Stores a short word of data to the user-space address base.
suswintr() Stores a short word of data to the user-space address base.
This function is safe to call during an interrupt context.
suword() Stores a word of data to the user-space address base.
The store functions return 0 on success or -1 on failure.
NetBSD 7.1.2 January 7, 1996 NetBSD 7.1.2