- NetBSD Manual Pages
RARPD(8) NetBSD System Manager's Manual RARPD(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rarpd -- Reverse ARP Daemon
rarpd [-adfl] [interface [...]]
rarpd services Reverse ARP requests on the Ethernet connected to
interface. Upon receiving a request, rarpd maps the target hardware
address to an IP address via its name, which must be present in both the
ethers(5) and hosts(5) databases. If a host does not exist in both data-
bases the translation cannot proceed and a reply will not be sent.
In normal operation, rarpd forks a copy of itself and runs in the back-
ground. Anomalies and errors are reported via syslog(3).
-a Listen on all the Ethernets attached to the system. If `-a' is
omitted, an interface must be specified.
-d Run in debug mode, with all the output to stderr. This option
implies the -f option.
-f Run in the foreground.
-l Log all requests to syslog.
Finlayson, R., Mann, T., Mogul, J.C., and Theimer, M., A Reverse Address
Resolution Protocol, RFC 903.
Craig Leres (email@example.com) and Steven McCanne (firstname.lastname@example.org).
Lawrence Berkeley Laboratory, University of California, Berkeley, CA.
NetBSD 7.1.2 October 17, 2002 NetBSD 7.1.2